What’s Vulnerable › Vulnerabilities
CVE-2021-3748
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-23 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free vulnerability was found in the virtio-net device of QEMU. It could occur when the descriptor's address belongs to the non direct access region, due to num_buffers being set after the virtqueue elem has been unmapped. A malicious guest could use this flaw to crash QEMU, resulting in a denial of service condition, or potentially execute code on the host with the privileges of the QEMU process.
Affected products
- Canonical Ubuntu Linux: 18.04, 20.04, 21.10
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 34
- QEMU: from 0.10.0 before 6.2.0 — fixed in 6.2.0
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Advanced Virtualization Eus: 8.4
How to fix
Upgrade to a fixed version: QEMU 6.2.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1998514
- https://github.com/qemu/qemu/commit/bedd7e93d01961fcb16a97ae45d93acf357e11f6
- https://lists.debian.org/debian-lts-announce/2022/04/msg00002.html
- https://lists.debian.org/debian-lts-announce/2022/09/msg00008.html
- https://lists.nongnu.org/archive/html/qemu-devel/2021-09/msg00388.html
- https://security.gentoo.org/glsa/202208-27
- https://security.netapp.com/advisory/ntap-20220425-0004/
- https://ubuntu.com/security/CVE-2021-3748
- https://bugzilla.redhat.com/show_bug.cgi?id=1998514
- https://github.com/qemu/qemu/commit/bedd7e93d01961fcb16a97ae45d93acf357e11f6
- https://lists.debian.org/debian-lts-announce/2022/04/msg00002.html
- https://lists.debian.org/debian-lts-announce/2022/09/msg00008.html
Get alerted when CVE-2021-3748 or the next vulnerability affects your stack