What’s Vulnerable › Vulnerabilities
CVE-2021-3761: OctoRPKI lacks contextual out-of-bounds check when validating RPKI ROA maxLength values
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-09 · updated 2026-06-17
- Weakness: CWE-787
Description
Any CA issuer in the RPKI can trick OctoRPKI prior to 1.3.0 into emitting an invalid VRP "MaxLength" value, causing RTR sessions to terminate. An attacker can use this to disable RPKI Origin Validation in a victim network (for example AS 13335 - Cloudflare) prior to launching a BGP hijack which during normal operations would be rejected as "RPKI invalid". Additionally, in certain deployments RTR session flapping in and of itself also could cause BGP routing churn, causing availability issues.
Affected products
- Cloudflare octorpki: before 1.3.0 — fixed in 1.3.0
- Debian Linux: 11.0
How to fix
Upgrade to a fixed version: Cloudflare octorpki 1.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/cloudflare/cfrpki/security/advisories/GHSA-c8xp-8mf3-62h9
- https://www.debian.org/security/2022/dsa-5041
- https://github.com/cloudflare/cfrpki/security/advisories/GHSA-c8xp-8mf3-62h9
- https://www.debian.org/security/2022/dsa-5041
Get alerted when CVE-2021-3761 or the next vulnerability affects your stack