What’s Vulnerable › Vulnerabilities
CVE-2021-37621: Denial of service due to infinite loop in Image::printIFDStructure
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-09 · updated 2026-06-17
- Weakness: CWE-835
Description
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An infinite loop was found in Exiv2 versions v0.27.4 and earlier. The infinite loop is triggered when Exiv2 is used to print the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when printing the image ICC profile, which is a less frequently used Exiv2 operation that requires an extra command line option (`-p C`). The bug is fixed in version v0.27.5.
Affected products
- Debian Linux: 10.0
- exiv2: through 0.27.4
- Fedoraproject Fedora: 33, 34
References
- https://github.com/Exiv2/exiv2/pull/1778
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-m479-7frc-gqqg
- https://lists.debian.org/debian-lts-announce/2023/01/msg00004.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FMDT4PJB7P43WSOM3TRQIY3J33BAFVVE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UYGDELIFFJWKUU7SO3QATCIXCZJERGAC/
- https://security.gentoo.org/glsa/202312-06
- https://github.com/Exiv2/exiv2/pull/1778
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-m479-7frc-gqqg
- https://lists.debian.org/debian-lts-announce/2023/01/msg00004.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FMDT4PJB7P43WSOM3TRQIY3J33BAFVVE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UYGDELIFFJWKUU7SO3QATCIXCZJERGAC/
- https://security.gentoo.org/glsa/202312-06
Get alerted when CVE-2021-37621 or the next vulnerability affects your stack