What’s Vulnerable › Vulnerabilities
CVE-2021-37627: Privilege escalation via form generator
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-269
Description
Contao is an open source CMS that allows creation of websites and scalable web applications. In affected versions it is possible to gain privileged rights in the Contao back end. Installations are only affected if they have untrusted back end users who have access to the form generator. All users are advised to update to Contao 4.4.56, 4.9.18 or 4.11.7. As a workaround users may disable the form generator or disable the login for untrusted back end users.
Affected products
- contao: from 4.4.0 before 4.4.56; from 4.9.0 before 4.9.18; from 4.11.0 before 4.11.7; 4.0.0, 4.1.0, 4.2.0, 4.3.0, 4.5.0, 4.6.0 (+3) — fixed in 4.11.7, 4.4.56, 4.9.18
How to fix
Upgrade to a fixed version: contao 4.11.7, 4.4.56, 4.9.18. Check the vendor advisory for mitigations.
References
- https://contao.org/en/security-advisories/privilege-escalation-with-the-form-generator.html
- https://github.com/contao/contao/security/advisories/GHSA-hq5m-mqmx-fw6m
- https://contao.org/en/security-advisories/privilege-escalation-with-the-form-generator.html
- https://github.com/contao/contao/security/advisories/GHSA-hq5m-mqmx-fw6m
Get alerted when CVE-2021-37627 or the next vulnerability affects your stack