What’s Vulnerable › Vulnerabilities
CVE-2021-37646: Bad alloc in `StringNGrams` caused by integer conversion in TensorFlow
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-12 · updated 2026-06-17
- Weakness: CWE-681
Description
TensorFlow is an end-to-end open source platform for machine learning. In affected versions the implementation of `tf.raw_ops.StringNGrams` is vulnerable to an integer overflow issue caused by converting a signed integer value to an unsigned one and then allocating memory based on this value. The [implementation](https://github.com/tensorflow/tensorflow/blob/8d72537c6abf5a44103b57b9c2e22c14f5f49698/tensorflow/core/kernels/string_ngrams_op.cc#L184) calls `reserve` on a `tstring` with a value that sometimes can be negative if user supplies negative `ngram_widths`. The `reserve` method calls `TF_TString_Reserve` which has an `unsigned long` argument for the size of the buffer. Hence, the implicit conversion transforms the negative value to a large integer. We have patched the issue in GitHub commit c283e542a3f422420cfdb332414543b62fc4e4a5. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.
Affected products
- tensorflow: from 2.3.0 before 2.3.4; from 2.4.0 before 2.4.3; 2.5.0, 2.6.0-rc0, 2.6.0-rc1, 2.6.0-rc2 — fixed in 2.3.4, 2.4.3
How to fix
Upgrade to a fixed version: tensorflow 2.3.4, 2.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/c283e542a3f422420cfdb332414543b62fc4e4a5
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-h6jh-7gv5-28vg
- https://github.com/tensorflow/tensorflow/commit/c283e542a3f422420cfdb332414543b62fc4e4a5
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-h6jh-7gv5-28vg
Get alerted when CVE-2021-37646 or the next vulnerability affects your stack