What’s Vulnerable › Vulnerabilities
CVE-2021-3767: Cross-site Scripting (XSS) - Stored in bookstackapp/bookstack
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-06 · updated 2026-06-17
- Weakness: CWE-79
Description
bookstack is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- bookstackapp/bookstack: before 21.08.2 — fixed in 21.08.2
How to fix
Upgrade to a fixed version: bookstackapp/bookstack 21.08.2. Check the vendor advisory for mitigations.
References
- https://github.com/bookstackapp/bookstack/commit/040997fdc4414776bcac06a3cbaac3b26b5e8a64
- https://huntr.dev/bounties/7ec92c85-30eb-4071-8891-6183446ca980
- https://github.com/bookstackapp/bookstack/commit/040997fdc4414776bcac06a3cbaac3b26b5e8a64
- https://huntr.dev/bounties/7ec92c85-30eb-4071-8891-6183446ca980
Get alerted when CVE-2021-3767 or the next vulnerability affects your stack