What’s Vulnerable › Vulnerabilities
CVE-2021-37671: Reference binding to nullptr in map operations in TensorFlow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-12 · updated 2026-06-17
- Weakness: CWE-824
Description
TensorFlow is an end-to-end open source platform for machine learning. In affected versions an attacker can cause undefined behavior via binding a reference to null pointer in `tf.raw_ops.Map*` and `tf.raw_ops.OrderedMap*` operations. The [implementation](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/core/kernels/map_stage_op.cc#L222-L248) has a check in place to ensure that `indices` is in ascending order, but does not check that `indices` is not empty. We have patched the issue in GitHub commit 532f5c5a547126c634fefd43bbad1dc6417678ac. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.
Affected products
- tensorflow: from 2.3.0 before 2.3.4; from 2.4.0 before 2.4.3; 2.5.0, 2.6.0-rc0, 2.6.0-rc1, 2.6.0-rc2 — fixed in 2.3.4, 2.4.3
How to fix
Upgrade to a fixed version: tensorflow 2.3.4, 2.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/532f5c5a547126c634fefd43bbad1dc6417678ac
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-qr82-2c78-4m8h
- https://github.com/tensorflow/tensorflow/commit/532f5c5a547126c634fefd43bbad1dc6417678ac
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-qr82-2c78-4m8h
Get alerted when CVE-2021-37671 or the next vulnerability affects your stack