What’s Vulnerable › Vulnerabilities
CVE-2021-37677: Missing validation in shape inference for `Dequantize` in TensorFlow
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-12 · updated 2026-06-17
- Weakness: CWE-20
Description
TensorFlow is an end-to-end open source platform for machine learning. In affected versions the shape inference code for `tf.raw_ops.Dequantize` has a vulnerability that could trigger a denial of service via a segfault if an attacker provides invalid arguments. The shape inference [implementation](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/core/ops/array_ops.cc#L2999-L3014) uses `axis` to select between two different values for `minmax_rank` which is then used to retrieve tensor dimensions. However, code assumes that `axis` can be either `-1` or a value greater than `-1`, with no validation for the other values. We have patched the issue in GitHub commit da857cfa0fde8f79ad0afdbc94e88b5d4bbec764. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.
Affected products
- tensorflow: from 2.3.0 before 2.3.4; from 2.4.0 before 2.4.3; 2.5.0, 2.6.0-rc0, 2.6.0-rc1, 2.6.0-rc2 — fixed in 2.3.4, 2.4.3
How to fix
Upgrade to a fixed version: tensorflow 2.3.4, 2.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/da857cfa0fde8f79ad0afdbc94e88b5d4bbec764
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-qfpc-5pjr-mh26
- https://github.com/tensorflow/tensorflow/commit/da857cfa0fde8f79ad0afdbc94e88b5d4bbec764
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-qfpc-5pjr-mh26
Get alerted when CVE-2021-37677 or the next vulnerability affects your stack