What’s Vulnerable › Vulnerabilities
CVE-2021-3768: Cross-site Scripting (XSS) - Stored in bookstackapp/bookstack
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-06 · updated 2026-06-17
- Weakness: CWE-79
Description
bookstack is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- bookstackapp/bookstack: before 21.08.2 — fixed in 21.08.2
How to fix
Upgrade to a fixed version: bookstackapp/bookstack 21.08.2. Check the vendor advisory for mitigations.
References
- https://github.com/bookstackapp/bookstack/commit/5e6092aaf8fd420202016038286554860bf8ea64
- https://huntr.dev/bounties/64a0229f-ff5e-4c64-b83e-9bfc0698a78e
- https://github.com/bookstackapp/bookstack/commit/5e6092aaf8fd420202016038286554860bf8ea64
- https://huntr.dev/bounties/64a0229f-ff5e-4c64-b83e-9bfc0698a78e
Get alerted when CVE-2021-3768 or the next vulnerability affects your stack