What’s Vulnerable › Vulnerabilities
CVE-2021-37685: Heap OOB in TensorFlow Lite
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-12 · updated 2026-06-17
- Weakness: CWE-125
Description
TensorFlow is an end-to-end open source platform for machine learning. In affected versions TFLite's [`expand_dims.cc`](https://github.com/tensorflow/tensorflow/blob/149562d49faa709ea80df1d99fc41d005b81082a/tensorflow/lite/kernels/expand_dims.cc#L36-L50) contains a vulnerability which allows reading one element outside of bounds of heap allocated data. If `axis` is a large negative value (e.g., `-100000`), then after the first `if` it would still be negative. The check following the `if` statement will pass and the `for` loop would read one element before the start of `input_dims.data` (when `i = 0`). We have patched the issue in GitHub commit d94ffe08a65400f898241c0374e9edc6fa8ed257. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.
Affected products
- tensorflow: from 2.3.0 before 2.3.4; from 2.4.0 before 2.4.3; 2.5.0, 2.6.0-rc0, 2.6.0-rc1, 2.6.0-rc2 — fixed in 2.3.4, 2.4.3
How to fix
Upgrade to a fixed version: tensorflow 2.3.4, 2.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/d94ffe08a65400f898241c0374e9edc6fa8ed257
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-c545-c4f9-rf6v
- https://github.com/tensorflow/tensorflow/commit/d94ffe08a65400f898241c0374e9edc6fa8ed257
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-c545-c4f9-rf6v
Get alerted when CVE-2021-37685 or the next vulnerability affects your stack