What’s Vulnerable › Vulnerabilities
CVE-2021-37691: Division by zero in LSH in TensorFlow Lite
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-12 · updated 2026-06-17
- Weakness: CWE-369
Description
TensorFlow is an end-to-end open source platform for machine learning. In affected versions an attacker can craft a TFLite model that would trigger a division by zero error in LSH [implementation](https://github.com/tensorflow/tensorflow/blob/149562d49faa709ea80df1d99fc41d005b81082a/tensorflow/lite/kernels/lsh_projection.cc#L118). We have patched the issue in GitHub commit 0575b640091680cfb70f4dd93e70658de43b94f9. The fix will be included in TensorFlow 2.6.0. We will also cherrypick thiscommit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.
Affected products
- tensorflow: from 2.3.0 before 2.3.4; from 2.4.0 before 2.4.3; 2.5.0, 2.6.0-rc0, 2.6.0-rc1, 2.6.0-rc2 — fixed in 2.3.4, 2.4.3
How to fix
Upgrade to a fixed version: tensorflow 2.3.4, 2.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/0575b640091680cfb70f4dd93e70658de43b94f9
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-27qf-jwm8-g7f3
- https://github.com/tensorflow/tensorflow/commit/0575b640091680cfb70f4dd93e70658de43b94f9
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-27qf-jwm8-g7f3
Get alerted when CVE-2021-37691 or the next vulnerability affects your stack