What’s Vulnerable › Vulnerabilities
CVE-2021-37698: Missing TLS service certificate validation in GelfWriter, ElasticsearchWriter, InfluxdbWriter and Influxdb2Writer
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-19 · updated 2026-06-17
- Weakness: CWE-295
Description
Icinga is a monitoring system which checks the availability of network resources, notifies users of outages, and generates performance data for reporting. In versions 2.5.0 through 2.13.0, ElasticsearchWriter, GelfWriter, InfluxdbWriter and Influxdb2Writer do not verify the server's certificate despite a certificate authority being specified. Icinga 2 instances which connect to any of the mentioned time series databases (TSDBs) using TLS over a spoofable infrastructure should immediately upgrade to version 2.13.1, 2.12.6, or 2.11.11 to patch the issue. Such instances should also change the credentials (if any) used by the TSDB writer feature to authenticate against the TSDB. There are no workarounds aside from upgrading.
Affected products
- Debian Linux: 9.0
- icinga2: from 2.5.0 before 2.11.10; from 2.12.0 before 2.12.6; from 2.13.0 before 2.13.1 — fixed in 2.11.10, 2.12.6, 2.13.1
How to fix
Upgrade to a fixed version: icinga2 2.11.10, 2.12.6, 2.13.1. Check the vendor advisory for mitigations.
References
- https://github.com/Icinga/icinga2/releases/tag/v2.11.11
- https://github.com/Icinga/icinga2/releases/tag/v2.12.6
- https://github.com/Icinga/icinga2/releases/tag/v2.13.1
- https://github.com/Icinga/icinga2/security/advisories/GHSA-cxfm-8j5v-5qr2
- https://lists.debian.org/debian-lts-announce/2021/11/msg00010.html
- https://github.com/Icinga/icinga2/releases/tag/v2.11.11
- https://github.com/Icinga/icinga2/releases/tag/v2.12.6
- https://github.com/Icinga/icinga2/releases/tag/v2.13.1
- https://github.com/Icinga/icinga2/security/advisories/GHSA-cxfm-8j5v-5qr2
- https://lists.debian.org/debian-lts-announce/2021/11/msg00010.html
- https://lists.debian.org/debian-lts-announce/2024/11/msg00010.html
Get alerted when CVE-2021-37698 or the next vulnerability affects your stack