What’s Vulnerable › Vulnerabilities
CVE-2021-37699: Open Redirect in Next.js versions below 11.1.0
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-12 · updated 2026-06-17
- Weakness: CWE-601
Description
Next.js is an open source website development framework to be used with the React library. In affected versions specially encoded paths could be used when pages/_error.js was statically generated allowing an open redirect to occur to an external site. In general, this redirect does not directly harm users although can allow for phishing attacks by redirecting to an attacker's domain from a trusted domain. We recommend everyone to upgrade regardless of whether you can reproduce the issue or not. The issue has been patched in release 11.1.0.
Affected products
- Next.js: from 10.0.5 through 10.2.0; from 11.0.0 through 11.0.1
References
- https://github.com/vercel/next.js/releases/tag/v11.1.0
- https://github.com/vercel/next.js/security/advisories/GHSA-vxf5-wxwp-m7g9
- https://github.com/vercel/next.js/releases/tag/v11.1.0
- https://github.com/vercel/next.js/security/advisories/GHSA-vxf5-wxwp-m7g9
Get alerted when CVE-2021-37699 or the next vulnerability affects your stack