What’s Vulnerable › Vulnerabilities
CVE-2021-3770: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-06 · updated 2026-06-17
- Weakness: CWE-122
Description
vim is vulnerable to Heap-based Buffer Overflow
Affected products
- Fedoraproject Fedora: 33, 34, 35
- NetApp ONTAP Select Deploy administration utility: all versions
- vim/vim: before 8.2.3408 — fixed in 8.2.3408
How to fix
Upgrade to a fixed version: vim/vim 8.2.3408. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/10/01/1
- https://github.com/vim/vim/commit/b7081e135a16091c93f6f5f7525a5c58fb7ca9f9
- https://huntr.dev/bounties/016ad2f2-07c1-4d14-a8ce-6eed10729365
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/J2CJLY3CF55I2ULG2X4ENXLSXAXYW5J4/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/X4FFQARG3LGREPDZRI4C7ERQL3RJKEWQ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZFNTMVZCN4TRTTCAXRLVQ7H2P7FYAIZQ/
- https://security.gentoo.org/glsa/202208-32
- https://security.netapp.com/advisory/ntap-20221124-0003/
- http://www.openwall.com/lists/oss-security/2021/10/01/1
- https://github.com/vim/vim/commit/b7081e135a16091c93f6f5f7525a5c58fb7ca9f9
- https://huntr.dev/bounties/016ad2f2-07c1-4d14-a8ce-6eed10729365
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/J2CJLY3CF55I2ULG2X4ENXLSXAXYW5J4/
Get alerted when CVE-2021-3770 or the next vulnerability affects your stack