What’s Vulnerable › Vulnerabilities
CVE-2021-37703: Information exposure in Discourse
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-13 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an open-source platform for community discussion. In Discourse before versions 2.7.8 and 2.8.0.beta5, a user's read state for a topic such as the last read post number and the notification level is exposed.
Affected products
- discourse: before 2.7.8; 2.8.0-beta1, 2.8.0-beta2, 2.8.0-beta3, 2.8.0-beta4 — fixed in 2.7.8
How to fix
Upgrade to a fixed version: discourse 2.7.8. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/aed65ec16d38886d7be7209d8c02df4ffd4937a4
- https://github.com/discourse/discourse/security/advisories/GHSA-gq2h-qhg2-phf9
- https://github.com/discourse/discourse/commit/aed65ec16d38886d7be7209d8c02df4ffd4937a4
- https://github.com/discourse/discourse/security/advisories/GHSA-gq2h-qhg2-phf9
Get alerted when CVE-2021-37703 or the next vulnerability affects your stack