What’s Vulnerable › Vulnerabilities
CVE-2021-37707: Manipulation of product reviews via API
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-16 · updated 2026-06-17
- Weakness: CWE-20
Description
Shopware is an open source eCommerce platform. Versions prior to 6.4.3.1 contain a vulnerability that allows manipulation of product reviews via API. Version 6.4.3.1 contains a patch. As workarounds for older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.
Affected products
- shopware: from 6.1.0 before 6.4.3.1 — fixed in 6.4.3.1
How to fix
Upgrade to a fixed version: shopware 6.4.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/platform/commit/912b96de3b839c6c5525c98cbb58f537c2d838be
- https://github.com/shopware/platform/security/advisories/GHSA-9f8f-574q-8jmf
- https://github.com/shopware/platform/commit/912b96de3b839c6c5525c98cbb58f537c2d838be
- https://github.com/shopware/platform/security/advisories/GHSA-9f8f-574q-8jmf
Get alerted when CVE-2021-37707 or the next vulnerability affects your stack