What’s Vulnerable › Vulnerabilities
CVE-2021-37708: Command injection in mail agent settings
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-16 · updated 2026-06-17
- Weakness: CWE-77
Description
Shopware is an open source eCommerce platform. Versions prior to 6.4.3.1 contain a command injection vulnerability in mail agent settings. Version 6.4.3.1 contains a patch. As workarounds for older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.
Affected products
- shopware: from 6.1.0 before 6.4.3.1 — fixed in 6.4.3.1
How to fix
Upgrade to a fixed version: shopware 6.4.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/platform/commit/82d8d1995f6ce9054323b2c3522b1b3cf04853aa
- https://github.com/shopware/platform/security/advisories/GHSA-xh55-2fqp-p775
- https://github.com/shopware/platform/commit/82d8d1995f6ce9054323b2c3522b1b3cf04853aa
- https://github.com/shopware/platform/security/advisories/GHSA-xh55-2fqp-p775
Get alerted when CVE-2021-37708 or the next vulnerability affects your stack