What’s Vulnerable › Vulnerabilities
CVE-2021-37710: Cross-Site Scripting via SVG media files
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Shopware is an open source eCommerce platform. Versions prior to 6.4.3.1 contain a Cross-Site Scripting vulnerability via SVG media files. Version 6.4.3.1 contains a patch. As workarounds for older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.
Affected products
- shopware: before 6.4.3.1 — fixed in 6.4.3.1
How to fix
Upgrade to a fixed version: shopware 6.4.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/platform/commit/abe9f69e1f667800f974acccd3047b4930e4b423
- https://github.com/shopware/platform/security/advisories/GHSA-fc38-mxwr-pfhx
- https://github.com/shopware/platform/commit/abe9f69e1f667800f974acccd3047b4930e4b423
- https://github.com/shopware/platform/security/advisories/GHSA-fc38-mxwr-pfhx
Get alerted when CVE-2021-37710 or the next vulnerability affects your stack