What’s Vulnerable › Vulnerabilities
CVE-2021-37716
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-07 · updated 2026-06-17
- Weakness: CWE-120
Description
A remote buffer overflow vulnerability was discovered in Aruba SD-WAN Software and Gateways; Aruba Operating System Software version(s): Prior to 8.6.0.4-2.2.0.4; Prior to 8.7.1.2, 8.6.0.8, 8.5.0.12, 8.3.0.15. Aruba has released patches for Aruba SD-WAN Software and Gateways and ArubaOS that address this security vulnerability.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 8.3.0.0 before 8.3.0.15; from 8.5.0.0 before 8.5.0.12; from 8.6.0.0 before 8.6.0.8; from 8.7.0.0 before 8.7.1.2 — fixed in 8.3.0.15, 8.5.0.12, 8.6.0.8, 8.7.1.2
- Arubanetworks Sd-Wan: from 2.2.0.0 before 2.2.0.4 — fixed in 2.2.0.4
- Siemens Scalance W1750D Firmware: before 8.7.1.3 — fixed in 8.7.1.3
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 8.3.0.15, 8.5.0.12, 8.6.0.8, 8.7.1.2; Arubanetworks Sd-Wan 2.2.0.4; Siemens Scalance W1750D Firmware 8.7.1.3. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-280624.pdf
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2021-016.txt
- https://cert-portal.siemens.com/productcert/pdf/ssa-280624.pdf
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2021-016.txt
Get alerted when CVE-2021-37716 or the next vulnerability affects your stack