What’s Vulnerable › Vulnerabilities
CVE-2021-37748
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-28 · updated 2026-06-17
- Weakness: CWE-787
Description
Multiple buffer overflows in the limited configuration shell (/sbin/gs_config) on Grandstream HT801 devices before 1.0.29 allow remote authenticated users to execute arbitrary code as root via a crafted manage_if setting, thus bypassing the intended restrictions of this shell and taking full control of the device. There are default weak credentials that can be used to authenticate.
Affected products
- Grandstream Ht801 Firmware: before 1.0.29 — fixed in 1.0.29
How to fix
Upgrade to a fixed version: Grandstream Ht801 Firmware 1.0.29. Check the vendor advisory for mitigations.
References
- http://www.grandstream.com/products/gateways-and-atas/analog-telephone-adaptors/product/ht801
- https://github.com/SECFORCE/CVE-2021-37748
- https://www.secforce.com/blog/exploiting-grandstream-ht801-ata-cve-2021-37748-cve-2021-37915/
- http://www.grandstream.com/products/gateways-and-atas/analog-telephone-adaptors/product/ht801
- https://github.com/SECFORCE/CVE-2021-37748
- https://www.secforce.com/blog/exploiting-grandstream-ht801-ata-cve-2021-37748-cve-2021-37915/
Get alerted when CVE-2021-37748 or the next vulnerability affects your stack