What’s Vulnerable › Vulnerabilities
CVE-2021-3778: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-15 · updated 2026-06-17
- Weakness: CWE-122
Description
vim is vulnerable to Heap-based Buffer Overflow
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 33, 34, 35
- NetApp ONTAP Select Deploy administration utility: all versions
- vim/vim: before 8.2.3409 — fixed in 8.2.3409
How to fix
Upgrade to a fixed version: vim/vim 8.2.3409. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/10/01/1
- https://github.com/vim/vim/commit/65b605665997fad54ef39a93199e305af2fe4d7f
- https://huntr.dev/bounties/d9c17308-2c99-4f9f-a706-f7f72c24c273
- https://lists.debian.org/debian-lts-announce/2022/01/msg00003.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7K4JJBIH3OQSZRVTWKCJCDLGMFGQ5DOH/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/S42L4Z4DTW4LHLQ4FJ33VEOXRCBE7WN4/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TE62UMYBZE4AE53K6OBBWK32XQ7544QM/
- https://security.gentoo.org/glsa/202208-32
- https://security.netapp.com/advisory/ntap-20221118-0003/
- http://www.openwall.com/lists/oss-security/2021/10/01/1
- https://github.com/vim/vim/commit/65b605665997fad54ef39a93199e305af2fe4d7f
- https://huntr.dev/bounties/d9c17308-2c99-4f9f-a706-f7f72c24c273
Get alerted when CVE-2021-3778 or the next vulnerability affects your stack