What’s Vulnerable › Vulnerabilities
CVE-2021-3785: Cross-site Scripting (XSS) - Stored in yourls/yourls
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-15 · updated 2026-06-17
- Weakness: CWE-79
Description
yourls is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- yourls/yourls: before 1.8.2 — fixed in 1.8.2
How to fix
Upgrade to a fixed version: yourls/yourls 1.8.2. Check the vendor advisory for mitigations.
References
- https://github.com/yourls/yourls/commit/1d8e224ebabb8a4c75b97f026950ed710faab0ff
- https://huntr.dev/bounties/b4085d13-54fa-4419-a2ce-1d780cc31638
- https://github.com/yourls/yourls/commit/1d8e224ebabb8a4c75b97f026950ed710faab0ff
- https://huntr.dev/bounties/b4085d13-54fa-4419-a2ce-1d780cc31638
Get alerted when CVE-2021-3785 or the next vulnerability affects your stack