What’s Vulnerable › Vulnerabilities
CVE-2021-37915
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-28 · updated 2026-06-17
Description
An issue was discovered on the Grandstream HT801 Analog Telephone Adaptor before 1.0.29.8. From the limited configuration shell, it is possible to set the malicious gdb_debug_server variable. As a result, after a reboot, the device downloads and executes malicious scripts from an attacker-defined host.
Affected products
- Grandstream Ht801 Firmware: before 1.0.29.8 — fixed in 1.0.29.8
How to fix
Upgrade to a fixed version: Grandstream Ht801 Firmware 1.0.29.8. Check the vendor advisory for mitigations.
References
- http://firmware.grandstream.com/BETA/Release_Note_HT80x_1.0.29.8.pdf
- http://www.grandstream.com/products/gateways-and-atas/analog-telephone-adaptors/product/ht801
- https://www.secforce.com/blog/exploiting-grandstream-ht801-ata-cve-2021-37748-cve-2021-37915/
- http://firmware.grandstream.com/BETA/Release_Note_HT80x_1.0.29.8.pdf
- http://www.grandstream.com/products/gateways-and-atas/analog-telephone-adaptors/product/ht801
- https://www.secforce.com/blog/exploiting-grandstream-ht801-ata-cve-2021-37748-cve-2021-37915/
Get alerted when CVE-2021-37915 or the next vulnerability affects your stack