What’s Vulnerable › Vulnerabilities
CVE-2021-3796: Use After Free in vim/vim
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-15 · updated 2026-06-17
- Weakness: CWE-416
Description
vim is vulnerable to Use After Free
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 33, 34, 35
- NetApp ONTAP Select Deploy administration utility: all versions
- vim/vim: before 8.2.3428 — fixed in 8.2.3428
How to fix
Upgrade to a fixed version: vim/vim 8.2.3428. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/10/01/1
- https://github.com/vim/vim/commit/35a9a00afcb20897d462a766793ff45534810dc3
- https://huntr.dev/bounties/ab60b7f3-6fb1-4ac2-a4fa-4d592e08008d
- https://lists.debian.org/debian-lts-announce/2022/01/msg00003.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7K4JJBIH3OQSZRVTWKCJCDLGMFGQ5DOH/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/S42L4Z4DTW4LHLQ4FJ33VEOXRCBE7WN4/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TE62UMYBZE4AE53K6OBBWK32XQ7544QM/
- https://security.gentoo.org/glsa/202208-32
- https://security.netapp.com/advisory/ntap-20221118-0004/
- http://www.openwall.com/lists/oss-security/2021/10/01/1
- https://github.com/vim/vim/commit/35a9a00afcb20897d462a766793ff45534810dc3
- https://huntr.dev/bounties/ab60b7f3-6fb1-4ac2-a4fa-4d592e08008d
Get alerted when CVE-2021-3796 or the next vulnerability affects your stack