What’s Vulnerable › Vulnerabilities
CVE-2021-37970
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-08 · updated 2026-06-17
- Weakness: CWE-416
Description
Use after free in File System API in Google Chrome prior to 94.0.4606.54 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Affected products
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 33, 35
- Google Chrome: before 94.0.4606.54 — fixed in 94.0.4606.54
How to fix
Upgrade to a fixed version: Google Chrome 94.0.4606.54. Check the vendor advisory for mitigations.
References
- https://chromereleases.googleblog.com/2021/09/stable-channel-update-for-desktop_21.html
- https://crbug.com/1248030
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4DDW7HAHTS3SDVXBQUY4SURELO5D4X7R/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PM7MOYYHJSWLIFZ4TPJTD7MSA3HSSLV2/
- https://www.debian.org/security/2022/dsa-5046
- https://chromereleases.googleblog.com/2021/09/stable-channel-update-for-desktop_21.html
- https://crbug.com/1248030
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4DDW7HAHTS3SDVXBQUY4SURELO5D4X7R/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PM7MOYYHJSWLIFZ4TPJTD7MSA3HSSLV2/
- https://www.debian.org/security/2022/dsa-5046
Get alerted when CVE-2021-37970 or the next vulnerability affects your stack