What’s Vulnerable › Vulnerabilities
CVE-2021-3800
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-23 · updated 2026-06-17
- Weakness: CWE-200
Description
A flaw was found in glib before version 2.63.6. Due to random charset alias, pkexec can leak content from files owned by privileged users to unprivileged ones under the right condition.
Affected products
- Debian Linux: 10.0
- GNOME GLib: before 2.62.5; from 2.63.0 before 2.63.6 — fixed in 2.62.5, 2.63.6
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
How to fix
Upgrade to a fixed version: GNOME GLib 2.62.5, 2.63.6. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2021-3800
- https://bugzilla.redhat.com/show_bug.cgi?id=1938284
- https://gitlab.gnome.org/GNOME/glib/-/commit/3529bb4450a51995
- https://lists.debian.org/debian-lts-announce/2022/09/msg00020.html
- https://security.netapp.com/advisory/ntap-20221028-0004/
- https://www.openwall.com/lists/oss-security/2017/06/23/8
- https://access.redhat.com/security/cve/CVE-2021-3800
- https://bugzilla.redhat.com/show_bug.cgi?id=1938284
- https://gitlab.gnome.org/GNOME/glib/-/commit/3529bb4450a51995
- https://lists.debian.org/debian-lts-announce/2022/09/msg00020.html
- https://security.netapp.com/advisory/ntap-20221028-0004/
- https://www.openwall.com/lists/oss-security/2017/06/23/8
Get alerted when CVE-2021-3800 or the next vulnerability affects your stack