What’s Vulnerable › Vulnerabilities
CVE-2021-38084
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-03 · updated 2026-06-17
- Weakness: CWE-74
Description
An issue was discovered in the POP3 component of Courier Mail Server before 1.1.5. Meddler-in-the-middle attackers can pipeline commands after the POP3 STLS command, injecting plaintext commands into an encrypted user session.
Affected products
- Courier-Mta Courier Mail Server: before 1.1.5 — fixed in 1.1.5
How to fix
Upgrade to a fixed version: Courier-Mta Courier Mail Server 1.1.5. Check the vendor advisory for mitigations.
References
- https://sourceforge.net/p/courier/mailman/courier-imap/thread/cone.1382574216.483027.8082.1000%40monster.email-scan.com/#msg31555583
- https://sourceforge.net/p/courier/mailman/message/37329216/
- https://sourceforge.net/p/courier/mailman/courier-imap/thread/cone.1382574216.483027.8082.1000%40monster.email-scan.com/#msg31555583
- https://sourceforge.net/p/courier/mailman/message/37329216/
Get alerted when CVE-2021-38084 or the next vulnerability affects your stack