What’s Vulnerable › Vulnerabilities
CVE-2021-3811: Cross-site Scripting (XSS) - Reflected in pi-hole/adminlte
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-17 · updated 2026-06-17
- Weakness: CWE-79
Description
adminlte is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- pi-hole web: before 5.6 — fixed in 5.6
How to fix
Upgrade to a fixed version: pi-hole web 5.6. Check the vendor advisory for mitigations.
References
- https://github.com/pi-hole/adminlte/commit/f526716de7bb0fd382a64bcbbb33915c926f94bb
- https://huntr.dev/bounties/fa38c61f-4043-4872-bc85-7fe5ae5cc2e8
- https://github.com/pi-hole/adminlte/commit/f526716de7bb0fd382a64bcbbb33915c926f94bb
- https://huntr.dev/bounties/fa38c61f-4043-4872-bc85-7fe5ae5cc2e8
Get alerted when CVE-2021-3811 or the next vulnerability affects your stack