What’s Vulnerable › Vulnerabilities
CVE-2021-38140
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-10 · updated 2026-06-17
- Weakness: CWE-269
Description
The set_user extension module before 2.0.1 for PostgreSQL allows a potential privilege escalation using RESET SESSION AUTHORIZATION after set_user().
Affected products
- Set User Project Set User: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Set User Project Set User 2.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/pgaudit/set_user/compare/REL2_0_0...REL2_0_1
- https://github.com/pgaudit/set_user/releases/tag/REL2_0_1
- https://github.com/pgaudit/set_user/compare/REL2_0_0...REL2_0_1
- https://github.com/pgaudit/set_user/releases/tag/REL2_0_1
Get alerted when CVE-2021-38140 or the next vulnerability affects your stack