What’s Vulnerable › Vulnerabilities
CVE-2021-38148
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-07 · updated 2026-06-17
Description
Obsidian before 0.12.12 does not require user confirmation for non-http/https URLs.
Affected products
- Obsidian: before 0.12.12 — fixed in 0.12.12
How to fix
Upgrade to a fixed version: Obsidian 0.12.12. Check the vendor advisory for mitigations.
References
- https://forum.obsidian.md/t/obsidian-release-v0-12-12/21564
- https://forum.obsidian.md/t/obsidian-release-v0-12-12/21564
Get alerted when CVE-2021-38148 or the next vulnerability affects your stack