What’s Vulnerable › Vulnerabilities
CVE-2021-38182
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-14 · updated 2026-06-17
- Weakness: CWE-20
Description
Due to insufficient input validation of Kyma, authenticated users can pass a Header of their choice and escalate privileges which can completely compromise the cluster.
Affected products
- SAP SE Kyma: before 1.24.7 — fixed in 1.24.7
How to fix
Upgrade to a fixed version: SAP SE Kyma 1.24.7. Check the vendor advisory for mitigations.
References
- https://github.com/kyma-project/kyma/security/advisories/GHSA-2vjp-5q24-hqjv
- https://wiki.scn.sap.com/wiki/display/PSR/SAP+Security+Patch+Day+-+December+2021
- https://github.com/kyma-project/kyma/security/advisories/GHSA-2vjp-5q24-hqjv
- https://wiki.scn.sap.com/wiki/display/PSR/SAP+Security+Patch+Day+-+December+2021
Get alerted when CVE-2021-38182 or the next vulnerability affects your stack