What’s Vulnerable › Vulnerabilities
CVE-2021-38204
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-08 · updated 2026-06-17
- Weakness: CWE-416
Description
drivers/usb/host/max3421-hcd.c in the Linux kernel before 5.13.6 allows physically proximate attackers to cause a denial of service (use-after-free and panic) by removing a MAX-3421 USB device in certain situations.
Affected products
- Debian Linux: 9.0
- Linux kernel: before 5.13.6 — fixed in 5.13.6
How to fix
Upgrade to a fixed version: Linux kernel 5.13.6. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.13.6
- https://github.com/torvalds/linux/commit/b5fdf5c6e6bee35837e160c00ac89327bdad031b
- https://lists.debian.org/debian-lts-announce/2021/12/msg00012.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.13.6
- https://github.com/torvalds/linux/commit/b5fdf5c6e6bee35837e160c00ac89327bdad031b
- https://lists.debian.org/debian-lts-announce/2021/12/msg00012.html
Get alerted when CVE-2021-38204 or the next vulnerability affects your stack