What’s Vulnerable › Vulnerabilities
CVE-2021-38207
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-08 · updated 2026-06-17
- Weakness: CWE-120
Description
drivers/net/ethernet/xilinx/ll_temac_main.c in the Linux kernel before 5.12.13 allows remote attackers to cause a denial of service (buffer overflow and lockup) by sending heavy network traffic for about ten minutes.
Affected products
- Linux kernel: before 5.12.13 — fixed in 5.12.13
How to fix
Upgrade to a fixed version: Linux kernel 5.12.13. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.12.13
- https://github.com/torvalds/linux/commit/c364df2489b8ef2f5e3159b1dff1ff1fdb16040d
- https://security.netapp.com/advisory/ntap-20210902-0007/
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.12.13
- https://github.com/torvalds/linux/commit/c364df2489b8ef2f5e3159b1dff1ff1fdb16040d
- https://security.netapp.com/advisory/ntap-20210902-0007/
Get alerted when CVE-2021-38207 or the next vulnerability affects your stack