What’s Vulnerable › Vulnerabilities
CVE-2021-38291
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-12 · updated 2026-06-17
- Weakness: CWE-617
Description
FFmpeg version (git commit de8e6e67e7523e48bb27ac224a0b446df05e1640) suffers from a an assertion failure at src/libavutil/mathematics.c.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- FFmpeg: before 4.1.7; from 4.2.0 before 4.2.5; from 4.3.0 before 4.3.3; from 4.4.0 before 4.4.1 — fixed in 4.1.7, 4.2.5, 4.3.3, 4.4.1
How to fix
Upgrade to a fixed version: FFmpeg 4.1.7, 4.2.5, 4.3.3, 4.4.1. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2021/11/msg00012.html
- https://security.gentoo.org/glsa/202312-14
- https://trac.ffmpeg.org/ticket/9312
- https://www.debian.org/security/2021/dsa-4990
- https://www.debian.org/security/2021/dsa-4998
- https://lists.debian.org/debian-lts-announce/2021/11/msg00012.html
- https://security.gentoo.org/glsa/202312-14
- https://trac.ffmpeg.org/ticket/9312
- https://www.debian.org/security/2021/dsa-4990
- https://www.debian.org/security/2021/dsa-4998
Get alerted when CVE-2021-38291 or the next vulnerability affects your stack