What’s Vulnerable › Vulnerabilities

CVE-2021-38297

Description

Go before 1.16.9 and 1.17.x before 1.17.2 has a Buffer Overflow via large arguments in a function invocation from a WASM module, when GOARCH=wasm GOOS=js is used.

Affected products

How to fix

Upgrade to a fixed version: Go 1.16.9, 1.17.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-38297 or the next vulnerability affects your stack