What’s Vulnerable › Vulnerabilities
CVE-2021-3831: Cross-site Scripting (XSS) - Reflected in gnuboard/gnuboard5
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-14 · updated 2026-06-17
- Weakness: CWE-79
Description
gnuboard5 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- Gnuboard5: before 5.4.20 — fixed in 5.4.20
How to fix
Upgrade to a fixed version: Gnuboard5 5.4.20. Check the vendor advisory for mitigations.
References
- https://github.com/gnuboard/gnuboard5/commit/2e81619ea87bc9c0b4a073d8df3c7693a6fdbf0d
- https://huntr.dev/bounties/25775287-88cd-4f00-b978-692d627dff04
- https://github.com/gnuboard/gnuboard5/commit/2e81619ea87bc9c0b4a073d8df3c7693a6fdbf0d
- https://huntr.dev/bounties/25775287-88cd-4f00-b978-692d627dff04
Get alerted when CVE-2021-3831 or the next vulnerability affects your stack