What’s Vulnerable › Vulnerabilities
CVE-2021-38345: Brizy <= 1.0.125 and 1.0.127 – 2.3.11 Incorrect authorization checks allowing Post modification
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Brizy Page Builder plugin <= 2.3.11 for WordPress used an incorrect authorization check that allowed any logged-in user accessing any endpoint in the wp-admin directory to modify the content of any existing post or page created with the Brizy editor. An identical issue was found by another researcher in Brizy <= 1.0.125 and fixed in version 1.0.126, but the vulnerability was reintroduced in version 1.0.127.
Affected products
- Brizy.io Brizy - Page Builder: before 1.0.1.126; from 1.0.127 through 2.3.11 — fixed in 1.0.1.126
How to fix
Upgrade to a fixed version: Brizy.io Brizy - Page Builder 1.0.1.126. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/blog/2021/10/multiple-vulnerabilities-in-brizy-page-builder-plugin-allow-site-takeover/
- https://www.wordfence.com/blog/2021/10/multiple-vulnerabilities-in-brizy-page-builder-plugin-allow-site-takeover/
Get alerted when CVE-2021-38345 or the next vulnerability affects your stack