What’s Vulnerable › Vulnerabilities
CVE-2021-3837: Improper Authorization in openwhyd/openwhyd
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-03 · updated 2026-06-17
- Weakness: CWE-285
Description
openwhyd is vulnerable to Improper Authorization
Affected products
- openwhyd/openwhyd: before 1.45.12 — fixed in 1.45.12
How to fix
Upgrade to a fixed version: openwhyd/openwhyd 1.45.12. Check the vendor advisory for mitigations.
References
- https://github.com/openwhyd/openwhyd/commit/102a97bb082edc831cf35d27f9e5c4f55f10ae85
- https://huntr.dev/bounties/d66f90d6-1b5f-440d-8be6-cdffc9d4587e
- https://github.com/openwhyd/openwhyd/commit/102a97bb082edc831cf35d27f9e5c4f55f10ae85
- https://huntr.dev/bounties/d66f90d6-1b5f-440d-8be6-cdffc9d4587e
Get alerted when CVE-2021-3837 or the next vulnerability affects your stack