What’s Vulnerable › Vulnerabilities
CVE-2021-3840
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-12 · updated 2026-06-17
- Weakness: CWE-427
Description
A dependency confusion vulnerability was reported in the Antilles open-source software prior to version 1.0.1 that could allow for remote code execution during installation due to a package listed in requirements.txt not existing in the public package index (PyPi). MITRE classifies this weakness as an Uncontrolled Search Path Element (CWE-427) in which a private package dependency may be replaced by an unauthorized package of the same name published to a well-known public repository such as PyPi. The configuration has been updated to only install components built by Antilles, removing all other public package indexes. Additionally, the antilles-tools dependency has been published to PyPi.
Affected products
- Antilles: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Antilles 1.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/lenovo/Antilles/security/advisories/GHSA-hgc3-hp6x-wpgx
- https://github.com/lenovo/Antilles/security/advisories/GHSA-hgc3-hp6x-wpgx
Get alerted when CVE-2021-3840 or the next vulnerability affects your stack