What’s Vulnerable › Vulnerabilities
CVE-2021-38415: Fuji Electric Tellus Lite V-Simulator heap based buffer overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-20 · updated 2026-06-17
- Weakness: CWE-122
Description
Fuji Electric V-Server Lite and Tellus Lite V-Simulator prior to v4.0.12.0 is vulnerable a heap-based buffer overflow when parsing a specially crafted project file, which may allow an attacker to execute arbitrary code.
Affected products
- Fuji Electric V-Server Lite: before 4.0.12.0 — fixed in 4.0.12.0
- Fujielectric V-Simulator: before 4.0.12.0 — fixed in 4.0.12.0
How to fix
Upgrade to a fixed version: Fuji Electric V-Server Lite 4.0.12.0; Fujielectric V-Simulator 4.0.12.0. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-299-01
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-299-01
Get alerted when CVE-2021-38415 or the next vulnerability affects your stack