What’s Vulnerable › Vulnerabilities
CVE-2021-38425: eProsima Fast DDS Network Amplification
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-05 · updated 2026-06-17
- Weakness: CWE-406
Description
eProsima Fast DDS versions prior to 2.4.0 (#2269) are susceptible to exploitation when an attacker sends a specially crafted packet to flood a target device with unwanted traffic, which may result in a denial-of-service condition and information exposure.
Affected products
- eProsima Fast-DDS: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: eProsima Fast-DDS 2.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/eProsima/Fast-DDS
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-315-02
- https://github.com/eProsima/Fast-DDS
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-315-02
Get alerted when CVE-2021-38425 or the next vulnerability affects your stack