What’s Vulnerable › Vulnerabilities
CVE-2021-38433: RTI Connext DDS Professional and Connext DDS Secure Stack-based Buffer Overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-05 · updated 2026-06-17
- Weakness: CWE-121
Description
RTI Connext DDS Professional and Connext DDS Secure Versions 4.2x to 6.1.0 vulnerable to a stack-based buffer overflow, which may allow a local attacker to execute arbitrary code.
Affected products
- RTI Connext Professional: from 4.2 before 6.1.0 — fixed in 6.1.0
- RTI Connext Secure: from 4.2 before 6.1.0 — fixed in 6.1.0
How to fix
Upgrade to a fixed version: RTI Connext Professional 6.1.0; RTI Connext Secure 6.1.0. Check the vendor advisory for mitigations.
References
- https://support.rti.com/s/login/?ec=302&startURL=%2Fs%2F
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-315-02
- https://support.rti.com/s/login/?ec=302&startURL=%2Fs%2F
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-315-02
Get alerted when CVE-2021-38433 or the next vulnerability affects your stack