What’s Vulnerable › Vulnerabilities
CVE-2021-38441: Eclipse CycloneDDS Write-what-where Condition
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-05 · updated 2026-06-17
- Weakness: CWE-123
Description
Eclipse CycloneDDS versions prior to 0.8.0 are vulnerable to a write-what-where condition, which may allow an attacker to write arbitrary values in the XML parser.
Affected products
- Eclipse CycloneDDS: before 0.8.0 — fixed in 0.8.0
How to fix
Upgrade to a fixed version: Eclipse CycloneDDS 0.8.0. Check the vendor advisory for mitigations.
References
- https://projects.eclipse.org/projects/iot.cyclonedds
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-315-02
- https://projects.eclipse.org/projects/iot.cyclonedds
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-315-02
Get alerted when CVE-2021-38441 or the next vulnerability affects your stack