What’s Vulnerable › Vulnerabilities
CVE-2021-38445: OCI OpenDDS Secure Improper Handling of Length Parameter Inconsistency
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-05 · updated 2026-06-17
- Weakness: CWE-130
Description
OCI OpenDDS versions prior to 3.18.1 do not handle a length parameter consistent with the actual length of the associated data, which may allow an attacker to remotely execute arbitrary code.
Affected products
- OpenDDS: before 3.18.1 — fixed in 3.18.1
How to fix
Upgrade to a fixed version: OpenDDS 3.18.1. Check the vendor advisory for mitigations.
References
- https://opendds.org/
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-315-02
- https://opendds.org/
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-315-02
Get alerted when CVE-2021-38445 or the next vulnerability affects your stack