What’s Vulnerable › Vulnerabilities
CVE-2021-38487: Potential Network Amplification and Information Exposure in RTI Connext Professional and Connext Micro
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-05 · updated 2026-06-17
- Weakness: CWE-406
Description
RTI Connext Professional versions 4.1 to 6.1.0, and Connext Micro versions 2.4 and later are vulnerable when an attacker sends a specially crafted packet to flood target devices with unwanted traffic. This may result in a denial-of-service condition and information exposure.
Affected products
- RTI Connext Dds Micro: from 2.4
- RTI Connext Professional: from 4.2 before 6.1.0 — fixed in 6.1.0
- RTI Connext Secure: from 4.2 before 6.1.0 — fixed in 6.1.0
How to fix
Upgrade to a fixed version: RTI Connext Professional 6.1.0; RTI Connext Secure 6.1.0. Check the vendor advisory for mitigations.
References
- https://support.rti.com/s/login/?ec=302&startURL=%2Fs%2F
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-315-02
- https://www.rti.com/vulnerabilities/#cve-2021-38487
- https://support.rti.com/s/login/?ec=302&startURL=%2Fs%2F
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-315-02
Get alerted when CVE-2021-38487 or the next vulnerability affects your stack