What’s Vulnerable › Vulnerabilities
CVE-2021-38521
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects R6400 before 1.0.1.50, R7900P before 1.4.1.50, R8000P before 1.4.1.50, RAX75 before 1.0.1.62, and RAX80 before 1.0.1.62.
Affected products
- NETGEAR R6400 Firmware: before 1.0.1.50 — fixed in 1.0.1.50
- NETGEAR R7900P Firmware: before 1.4.1.50 — fixed in 1.4.1.50
- NETGEAR R8000P Firmware: before 1.4.1.50 — fixed in 1.4.1.50
- NETGEAR Rax75 Firmware: before 1.0.1.62 — fixed in 1.0.1.62
- NETGEAR Rax80 Firmware: before 1.0.1.62 — fixed in 1.0.1.62
How to fix
Upgrade to a fixed version: NETGEAR R6400 Firmware 1.0.1.50; NETGEAR R7900P Firmware 1.4.1.50; NETGEAR R8000P Firmware 1.4.1.50; NETGEAR Rax75 Firmware 1.0.1.62; NETGEAR Rax80 Firmware 1.0.1.62. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000063764/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-PSV-2018-0566
- https://kb.netgear.com/000063764/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-PSV-2018-0566
Get alerted when CVE-2021-38521 or the next vulnerability affects your stack