What’s Vulnerable › Vulnerabilities
CVE-2021-38525
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects D3600 before 1.0.0.76, D6000 before 1.0.0.76, D6200 before 1.1.00.36, D7000 before 1.0.1.70, EX6200v2 before 1.0.1.78, EX7000 before 1.0.1.78, EX8000 before 1.0.1.186, JR6150 before 1.0.1.18, PR2000 before 1.0.0.28, R6020 before 1.0.0.42, R6050 before 1.0.1.18, R6080 before 1.0.0.42, R6120 before 1.0.0.46, R6220 before 1.1.0.80, R6260 before 1.1.0.64, R6300v2 before 1.0.4.34, R6700 before 1.0.2.6, R6700v2 before 1.2.0.36, R6800 before 1.2.0.36, R6900 before 1.0.2.4, R6900P before 1.3.1.64, R6900v2 before 1.2.0.36, R7000 before 1.0.9.42, R7000P before 1.3.1.64, R7800 before 1.0.2.60, R8900 before 1.0.4.12, R9000 before 1.0.4.12, and XR500 before 2.3.2.40.
Affected products
- NETGEAR D3600 Firmware: before 1.0.0.76 — fixed in 1.0.0.76
- NETGEAR D6000 Firmware: before 1.0.0.76 — fixed in 1.0.0.76
- NETGEAR D6200 Firmware: before 1.1.00.36 — fixed in 1.1.00.36
- NETGEAR D7000 Firmware: before 1.0.1.70 — fixed in 1.0.1.70
- Netgear EX6200: before 1.0.1.78 — fixed in 1.0.1.78
- NETGEAR Ex7000 Firmware: before 1.0.1.78 — fixed in 1.0.1.78
- NETGEAR Ex8000 Firmware: before 1.0.1.186 — fixed in 1.0.1.186
- NETGEAR JR6150: before 1.0.1.18 — fixed in 1.0.1.18
- NETGEAR Pr2000 Firmware: before 1.0.0.28 — fixed in 1.0.0.28
- NETGEAR R6020 Firmware: before 1.0.0.42 — fixed in 1.0.0.42
- NETGEAR R6050 Firmware: before 1.0.1.18 — fixed in 1.0.1.18
- NETGEAR R6080 Firmware: before 1.0.0.42 — fixed in 1.0.0.42
- NETGEAR R6120 Firmware: before 1.0.0.46 — fixed in 1.0.0.46
- NETGEAR R6220 Firmware: before 1.1.0.80 — fixed in 1.1.0.80
- NETGEAR R6260: before 1.1.0.64 — fixed in 1.1.0.64
- NETGEAR R6300 Firmware: before 1.0.4.34 — fixed in 1.0.4.34
- NETGEAR R6700: before 1.0.2.6; before 1.2.0.36 — fixed in 1.0.2.6, 1.2.0.36
- NETGEAR R6800 Firmware: before 1.2.0.36 — fixed in 1.2.0.36
- NETGEAR R6900 Firmware: before 1.0.2.4; before 1.2.0.36 — fixed in 1.0.2.4, 1.2.0.36
- NETGEAR R6900P Firmware: before 1.3.1.64 — fixed in 1.3.1.64
- NETGEAR R7000: before 1.0.9.42 — fixed in 1.0.9.42
- NETGEAR R7000P: before 1.3.1.64 — fixed in 1.3.1.64
- NETGEAR R7800 Firmware: before 1.0.2.60 — fixed in 1.0.2.60
- NETGEAR R8900 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR R9000 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR Xr500 Firmware: before 2.3.2.40 — fixed in 2.3.2.40
How to fix
Upgrade to a fixed version: NETGEAR D3600 Firmware 1.0.0.76; NETGEAR D6000 Firmware 1.0.0.76; NETGEAR D6200 Firmware 1.1.00.36; NETGEAR D7000 Firmware 1.0.1.70; Netgear EX6200 1.0.1.78; NETGEAR Ex7000 Firmware 1.0.1.78; NETGEAR Ex8000 Firmware 1.0.1.186; NETGEAR JR6150 1.0.1.18; NETGEAR Pr2000 Firmware 1.0.0.28; NETGEAR R6020 Firmware 1.0.0.42; NETGEAR R6050 Firmware 1.0.1.18; NETGEAR R6080 Firmware 1.0.0.42. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000063759/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-Gateways-and-Extenders-PSV-2018-0378
- https://kb.netgear.com/000063759/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-Gateways-and-Extenders-PSV-2018-0378
Get alerted when CVE-2021-38525 or the next vulnerability affects your stack