What’s Vulnerable › Vulnerabilities
CVE-2021-38526
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an unauthenticated attacker. This affects RAX35 before 1.0.3.94, RAX38 before 1.0.3.94, and RAX40 before 1.0.3.94.
Affected products
- NETGEAR Rax35 Firmware: before 1.0.3.94 — fixed in 1.0.3.94
- NETGEAR Rax38 Firmware: before 1.0.3.94 — fixed in 1.0.3.94
- NETGEAR Rax40 Firmware: before 1.0.3.94 — fixed in 1.0.3.94
How to fix
Upgrade to a fixed version: NETGEAR Rax35 Firmware 1.0.3.94; NETGEAR Rax38 Firmware 1.0.3.94; NETGEAR Rax40 Firmware 1.0.3.94. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000063782/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2020-0416
- https://kb.netgear.com/000063782/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2020-0416
Get alerted when CVE-2021-38526 or the next vulnerability affects your stack