What’s Vulnerable › Vulnerabilities
CVE-2021-38528
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an unauthenticated attacker. This affects D8500 before 1.0.3.58, R6900P before 1.3.2.132, R7000P before 1.3.2.132, R7100LG before 1.0.0.64, WNDR3400v3 before 1.0.1.38, and XR300 before 1.0.3.56.
Affected products
- NETGEAR D8500 Firmware: before 1.0.3.58 — fixed in 1.0.3.58
- NETGEAR R6900P Firmware: before 1.3.2.132 — fixed in 1.3.2.132
- NETGEAR R7000P: before 1.3.2.132 — fixed in 1.3.2.132
- NETGEAR R7100Lg Firmware: before 1.0.0.64 — fixed in 1.0.0.64
- NETGEAR Wndr3400 Firmware: before 1.0.1.38 — fixed in 1.0.1.38
- NETGEAR Xr300 Firmware: before 1.0.3.56 — fixed in 1.0.3.56
How to fix
Upgrade to a fixed version: NETGEAR D8500 Firmware 1.0.3.58; NETGEAR R6900P Firmware 1.3.2.132; NETGEAR R7000P 1.3.2.132; NETGEAR R7100Lg Firmware 1.0.0.64; NETGEAR Wndr3400 Firmware 1.0.1.38; NETGEAR Xr300 Firmware 1.0.3.56. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000063781/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Gateways-and-Routers-PSV-2020-0297
- https://kb.netgear.com/000063781/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Gateways-and-Routers-PSV-2020-0297
Get alerted when CVE-2021-38528 or the next vulnerability affects your stack