What’s Vulnerable › Vulnerabilities
CVE-2021-38529
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an unauthenticated attacker. This affects D7800 before 1.0.1.56, R7800 before 1.0.2.68, R8900 before 1.0.4.26, and R9000 before 1.0.4.26.
Affected products
- NETGEAR D7800 Firmware: before 1.0.1.56 — fixed in 1.0.1.56
- NETGEAR R7800 Firmware: before 1.0.2.68 — fixed in 1.0.2.68
- NETGEAR R8900 Firmware: before 1.0.4.26 — fixed in 1.0.4.26
- NETGEAR R9000 Firmware: before 1.0.4.26 — fixed in 1.0.4.26
How to fix
Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.56; NETGEAR R7800 Firmware 1.0.2.68; NETGEAR R8900 Firmware 1.0.4.26; NETGEAR R9000 Firmware 1.0.4.26. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000063765/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-and-Gateways-PSV-2018-0616
- https://kb.netgear.com/000063765/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-and-Gateways-PSV-2018-0616
Get alerted when CVE-2021-38529 or the next vulnerability affects your stack